Hello Visitor :o)

My Latest Pic:
maleficent - beastly -->

Saturday, April 7, 2012

Fixing Bad States in SL

What is a Bad State? Getting seen as one of these:






WHY?

Information isn't getting across from the SL server to the Computer.

REALLY WHY?


  • When you wear (non prim) clothing, the textures are sent from SL Server to your computer.
  • When they are on your computer, the viewer layers the textures onto your skin textures -- This is called BAKING
  • Then the resultant texture is sent back to the SL Server.
  • The SL Server then gives that to other players in the region.
  • If any one of these things don't work properly, the result is called a BAKE FAIL.
  • BAKE FAIL = cloud, ruthed or the clothing doesn't change properly.
  • In order to ensure that your avatar is fixed disable this:
  • Advanced Menu > Debug Settings > type RenderUnloadedAvatar and set it to FALSE
  • If it's set to true what you see might be a lie.

FIRST AID
This is SL First Aid, it might help or it might not do anything but at least you tried.  I left out tools that people might not have like deruth rockets, but sprinkle the use of those in if you have them.


1. It looks good on my screen, but others say you look funny or you have two outfits on etc.


Step 1. Try: Change your active group
Step 2. Try: Rebake (Ctrl+Alt+R) a FEW times
Step 3. Try: Edit > Appearance (and try to edit anything and save the difference); Exit Appearance
Step 4. if Everything above fails then info from your Computer is not getting to the SL Sever.  Try Relogging.  Still nothing?  Next step
Step 5. Check your bandwidth;  
  • If your bandwidth is TOO HIGH for your connection then you might have issues (you are trying to stuff a cannon ball (your SL) down a straw (your connection))
  • If your bandwidth is TOO LOW for your connection then you might also have issues
  • TECH: if you know your way around a computer check out this link at Phoenix to figure out the optimum bandwidth to use http://wiki.phoenixviewer.com/speedtest
Step 6.  If this is a consistent problem (like it happens every single day on SL), try this:
  • Reset your router (if you use one) and/or your cable modem. 
  • If that doesn't help, something on your Computer might be interfering with your client's connection to SL like a Firewall, or Anti-Virus.  Try to disable them TEMPORARILY and see if things improve.  If they do then you found your problem.

2. Your Avatar is Partly or Totally Transparent, or other Parts of the Avatar are Black.

Step 1. Try: Update your Video Card Driver

Step 2. Try: If you have more than one monitor, try moving SL to the primary monitor.

Step 3. Try: Edit > Preference > Graphics > and check Custom.  At the bottom disable "Hardware Skinning" and click "OK".  You might have to relog for the change to kick in.

Step 4. Try another technique (below)

3.  You see yourself as a Cloud, Ruthed, or Are Unable to Edit your Appearance.

Prep.  Disable RLV if you have it enabled, and RELOG before doing anything that involves wearing or removing clothes or attachments.

Step 1. Try: Change your active group.

Step 2. Try: Rebake (CTRL+ALT+R) a FEW times.

Step 3. Try: Edit > Appearance (and try to edit anything and save the difference); Exit Appearance

Step 4. Try: Replace your Hair Base with a different one, if it lets you.  If that works then you can replace it back with your usual.

Step 5. Try: Relogging.  Still nothing?  Next step

Step 6. Check your bandwidth;  
  • If your bandwidth is TOO HIGH for your connection then you might have issues (you are trying to stuff a cannon ball (your SL) down a straw (your connection))
  • If your bandwidth is TOO LOW for your connection then you might also have issues
  • TECH: if you know your way around a computer check out this link at Phoenix to figure out the optimum bandwidth to use http://wiki.phoenixviewer.com/speedtest (okay I did an example of one below -- scroll to the bottom of the post)
Step 7.  Try Disable Anti-Virus.  Try disabling them, then relogging. Some anti-viruses  inhibit textures from loading.  REMEMBER to RE-ENABLE your anti-virus later.  Don't leave your PC vulnerable.

Step 8.  Check: Make sure your inventory is fully loaded by manually clearing your cache.  People used to tell me to clear my cache when I was a newbie, but that really defeats the point of having a cache.  I was computer literate so I ignored them.  That said, the problem might be in your cache so this is a valid step.

Step 9.  Try: Replace Outfit.  Make a new temporary folder.  Copy your shape, skin, hair bases, eyes etc. into it.  Right click on the folder name and REPLACE OUTFIT (not add or wear or whatever)

Step 10.  Try: Character Tests.  Go to Advanced (Ctrl-Alt-D to activate) > Character > Character Tests > Test Male/Female.  This will turn you into a ruthed, noob avi and you'll have to rewear all your normal skin, clothes and attachments.  Rebake again and again and again.  If that works replace your normal avatar in the following order:

1. Hair Base
2. Eyes
3. Shape
4. Skin
5. Hair
6. Shirt
7. Pants
8. Shoes

Step 11.  Try: Download and install the offical SL Viewer.  Log in and remove everything you can.  Log out and log back with your regular viewer.  If you are still having issues, toggle HTTP Get a few times rebaking between each get.

There are more methods, but this should help getting you out of the bad state.  Sometimes the region is just too laggy and despite what people say lag gauge tools help a lot if you know how to read and use them. 




===


TC. I decided to put an example of speed testing.  It'll be a new lesson blog post later on.  But for now here's the quick and dirty of it:


POINTS:
* SL has data centers in Dallas, Phoenix and Culpeper.  You want to do speedtests to one or all of these cities to determine your best bandwidth.


HOW:
1. test at: http://dallastx.speedtest.net/, record the Download speed
2. test at: http://tuscon.speedtest.net/, record the Download speed
3. test at: http://reston.speedtest.net/, record the Download speed
4. Multiply each speed by 1024 (convert from Mbps to Kbps)
5. Multiply the lowest of those speeds by 80% (0.80)
6. Compare what you got at step 5. to the following:


Your connection is:
Wireless/WiFi: 500
Hardwired DSL: 1000
Hardwired Cable or Better: 1500


7. Use the lower of the two.


For example:
Download Speed = 19.78 x 1024  =  20254.72
Download Speed = 12.57 x 1024 = 12871.68

Download Speed = 26.12 x 1024 = 26746.88

Since 12,871.68 is my lowest 80% of that is 10,297.344 Kbps

This is greater than 1500 so my optimum bandwidth should be 1500 in SL.